Bug Guest login and Local Server

    WarSong

    Cmdr Deathmark
    Joined
    May 29, 2013
    Messages
    1,255
    Reaction score
    429
    So I was going through the steps a newbie might use to just kinda get their feet wet in the StarMade universe without committing to 'The Registry' and without using a live server. What with the game going open source. Here's how it went:
    1: downloaded and launched Steam demo version
    2: began playing as guest bypassing 'The Registry'
    3: started a local play session
    4: built a new universe (not using world0) and set creative inventory
    5: attempt to start universe results in dialog balking that server requires StarMade authorization and I should reinstall the game
    6: disable authorization requirement, relaunch
    7: stuck at Connecting to Universe loop

    Verifying demo files accomplished nothing. Ditto with reinstalling. Just repeats taking steps 5,6 and 7. As a modestly experience starmate I decided to see if the universe would load as a dedicated server and attempt some logins from another demo copy as a client. No joy. The server window shows no loaded universe. Additionally I attempted logging into to several servers as a guest and successfully joined one. Everything loaded fine and the tutorial began to roll. Controls were normal and my client was stable. Connecting to a Local server as a Guest refuses to function altho it is one of the stated purposes (in the launcher at least) of having a Guest login.

    This is pretty big UX issue. Can we just find a way to get an Instant Action (Creative Mode) button to simplify this for the end user? If I were a newbie I'd have given up the ghost at step 5. An inexperienced user (with other space building game options available) isn't very likely to dedicate time to using 'The Registry' much less trying to diagnose issues in a demo.
     
    Joined
    Jan 28, 2017
    Messages
    28
    Reaction score
    45
    could you upload the logfiles? starmade install -> logs -> log.0 file.
    maybe theres something obvious in them. Also: is it an issue solely with the steam version or also with the non-steam version?
     

    WarSong

    Cmdr Deathmark
    Joined
    May 29, 2013
    Messages
    1,255
    Reaction score
    429
    could you upload the logfiles? starmade install -> logs -> log.0 file.
    maybe theres something obvious in them. Also: is it an issue solely with the steam version or also with the non-steam version?
    well nuts... i was doing this from my laptop and i just realized i'm at my desktop in my office and, what do you know, no log files... cuz they on the laptop. bbiab

    ok, log files..
    attached, its the whole shebang just zipped up
    told ya i'd follow up :3
    but yeah i've not even looked at them tbh. i'm less interested in finding a work around vs just making it easier on the newbie starmates cuz thay baby. tho having an idea of what needs fixin' and giving the more determined folks something to get it working meantime is by no measure a bad thing. just not my personal goal. maek it ded simple. *bam* fresh crop of newbies making yt tutorials <3
     

    Attachments

    Last edited:

    AndyP

    Customer Experience Manager
    Joined
    Aug 15, 2013
    Messages
    1,186
    Reaction score
    259
    • Schine
    • Wired for Logic
    Well, there are a few things that do not look like a fresh installation at all.

    Authentication is by default disabled for local worlds.
    Yours was enabled (from log) : [AUTH] authenticating MossyStone48; useAuth: false; requireAuth: true

    You have also concurrent logfiles.
    That means an instance of the game was running when a second instance got started.
    As with every game, you can run either as a dedicated server or as a client.
    Running both from the same directory does not work.

    A few logs are spammed full with errors from a ship that is not shipped with the game at all:
    "[2021-03-27 05:57:01] Exception: Invalid slave Ship[Assailant-class Pirate Strikecraft 2543-1](76539); org.schema.game.co[email protected]7a4a2e55"

    You also connected to a multiplayer server and got rejected to join as this server has authentication enabled - to prevent identity theft and other problems you face without our registry being used.

    By default, a fresh installation from steam or from our site runs out of the box.
    You can run a single player world, that is also a server-client combo together. This way others can join your local world if you set up a network route to your computer from the other player(s).
    You can also run a fresh installation as a dedicated server - for any other computer in the network to join this game that runs 24/7 (assuming the server is not shut down).

    A good option would be uploading the logs to a newly created ticket (use tickets in the top row) as they contain quite a lot of information about your computer it may be best to not troubleshoot the details in public.

    - Andy
     

    WarSong

    Cmdr Deathmark
    Joined
    May 29, 2013
    Messages
    1,255
    Reaction score
    429
    Well, there are a few things that do not look like a fresh installation at all.

    Authentication is by default disabled for local worlds.
    Yours was enabled (from log) : [AUTH] authenticating MossyStone48; useAuth: false; requireAuth: true

    You have also concurrent logfiles.
    That means an instance of the game was running when a second instance got started.
    As with every game, you can run either as a dedicated server or as a client.
    Running both from the same directory does not work.

    A few logs are spammed full with errors from a ship that is not shipped with the game at all:
    "[2021-03-27 05:57:01] Exception: Invalid slave Ship[Assailant-class Pirate Strikecraft 2543-1](76539); org.schema.game.co[email protected]7a4a2e55"

    You also connected to a multiplayer server and got rejected to join as this server has authentication enabled - to prevent identity theft and other problems you face without our registry being used.

    By default, a fresh installation from steam or from our site runs out of the box.
    You can run a single player world, that is also a server-client combo together. This way others can join your local world if you set up a network route to your computer from the other player(s).
    You can also run a fresh installation as a dedicated server - for any other computer in the network to join this game that runs 24/7 (assuming the server is not shut down).

    A good option would be uploading the logs to a newly created ticket (use tickets in the top row) as they contain quite a lot of information about your computer it may be best to not troubleshoot the details in public.

    - Andy
    this was originally a fresh install from steam on a machine that was brand new out of the box and had never touched any of my old starmade files

    yes i did have concurrent versions running at one point, that was an oversight on my part
    also none of the server indicate if auth is in use or not
    i'm not a big fan of having to go through "The Registry" and i'm sure more than a few ppl who simply want to try the game and not commit to "The Registry" would use guest logins to bypass it, especially offline
    i only attempted online play to verify it wasn't some localized issue

    agreed on the ticket

    so this is several hours later April... i forgot to hit send on this..
    so yeah you shoulda seen this hours ago and didn't because... i dunno. blame obama


    edit: of note there's 490mb of files left after telling Steam to uninstall the game.. deleting manually. just odd..
     
    Last edited:

    AndyP

    Customer Experience Manager
    Joined
    Aug 15, 2013
    Messages
    1,186
    Reaction score
    259
    • Schine
    • Wired for Logic
    [...]

    edit: of note there's 490mb of files left after telling Steam to uninstall the game.. deleting manually. just odd..
    That is something to blame steam for.
    It does only remove files it actively puts in place.
    Any world, blueprint or alike is considered: Saved game data and will be untouched by steam.
    Even if you state its okay to remove everything....

    - Andy
     
    • Like
    Reactions: WarSong

    WarSong

    Cmdr Deathmark
    Joined
    May 29, 2013
    Messages
    1,255
    Reaction score
    429
    i keep forgetting to reply to these, sry.
    yes, i deleted the files manually on my second reinstall attempt, still no joy. i've filed a ticket outlining my steps in a third attempt but kept the extraneous files to dig out the log files later if requested. i've video on the third attempt here:
     
    Joined
    Jan 28, 2017
    Messages
    28
    Reaction score
    45
    you didnt disable authentifaction in your new install.
    Do you get stuck in an endless waiting cycle when trying to join a world with disabled Auth?
     

    WarSong

    Cmdr Deathmark
    Joined
    May 29, 2013
    Messages
    1,255
    Reaction score
    429
    it's the same as the original post. it just gets stuck like that.
    turns out they found the issue and passed it along to the right ppl but it seems like a gaffe in the Steam version where a Quickfire setting forces Auth. i've not figured a work around but i'd like to see this fixed because Spring Break showed me there's interest in the game but not enough to seek support if it doesn't work right out of the box.