AI Turrets stop firing at selected target

    Dr. Whammy

    Executive Constructologist of the United Star Axis
    Joined
    Jul 22, 2014
    Messages
    1,720
    Reaction score
    1,531
    • Thinking Positive
    • Top Forum Contributor
    • Legacy Citizen 5
    Hi Everyone,

    I've been experimenting with a few offensive turrets and I've noticed that the turrets seem to 'lose interest' in their target and stop firing. Here is the sequence of events I've been observing.

    1) I build turret and set AI to "Turret" and "selected target". Remote control is turned off.
    2) Spawn a target to test the weapon
    3) I select the target and the AI turrets aim at it and fire normally
    4) When the target's shields fail, the AI turret disengages and will not fire at that target anymore.
    5) If I spawn another target, the AI turret engages normally then stops firing when the new target's shields drop.

    Has anyone else seen this happen?

    Thanks in advance.
     
    Joined
    Aug 28, 2018
    Messages
    1
    Reaction score
    0
    I'm having the exact same issue while building mine... I guess it has been a long running issue.
     
    Joined
    Mar 31, 2015
    Messages
    280
    Reaction score
    92
    • Purchased!
    • Legacy Citizen 5
    Turrets shoot at the center of the target... which is a problem if there is nothing in the center anymore to shoot.
     
    Joined
    Mar 30, 2018
    Messages
    46
    Reaction score
    49
    I belive this has been a bug or problem since the power update, so i don't think this is going to get fixed anytime soon, look at when this was first posted, January 4 2019! More than a year ago! And we still have the same problem
     

    Dr. Whammy

    Executive Constructologist of the United Star Axis
    Joined
    Jul 22, 2014
    Messages
    1,720
    Reaction score
    1,531
    • Thinking Positive
    • Top Forum Contributor
    • Legacy Citizen 5
    I belive this has been a bug or problem since the power update, so i don't think this is going to get fixed anytime soon, look at when this was first posted, January 4 2019! More than a year ago! And we still have the same problem
    It will actually be 2 years in about a month and some change.

    Given that Schine's last relevant update on the status of this game was in January of this year, I don't see them ever fixing this. Kinda sad.