Starmade insists to update intel drivers despite not using an Intel card

    Joined
    Mar 26, 2020
    Messages
    2
    Reaction score
    1
    Essentially the title text- Starmade insists that my Intel drivers are out of date despite both A. Using an Nvidia GeForce GTX not an Intel card (IIRC nvidia isn't Intel) and B. Literally buying this brand-new computer 4 days ago.
    Am I missing something with the way my computer's setup (Am I actually using Intel instead or something) or is Starmade just throwing a hissy fit?
    Many thanks for any assistance provided.
     

    DrTarDIS

    Eldrich Timelord
    Joined
    Jan 16, 2014
    Messages
    1,032
    Reaction score
    281
    My friend had an issue on his ROG laptop where starmade would use the integrated intel graphics on the CPU instead of the GPU. Something about hybrid graphics and power saving features of the laptop, so I can see it being in place on some OEM desktops too.

    We did a week or so of diagnostics and research to fix it, but that was long enough ago that I can't point you to specifics...

    I DO remember there was some option in the NVIDIA control panel related to power saving that let us force the GPU into "always on" state that fixed the problem with starmade and java in general. Perhaps you can find that option.

    Edit: If you DO find that option, and it is a fix, it would be nice of you to post screenshots for anyone else that runs into that wall.
     
    • Like
    Reactions: AndyP and Agame3
    Joined
    Mar 26, 2020
    Messages
    2
    Reaction score
    1
    My friend had an issue on his ROG laptop where starmade would use the integrated intel graphics on the CPU instead of the GPU. Something about hybrid graphics and power saving features of the laptop, so I can see it being in place on some OEM desktops too.

    We did a week or so of diagnostics and research to fix it, but that was long enough ago that I can't point you to specifics...

    I DO remember there was some option in the NVIDIA control panel related to power saving that let us force the GPU into "always on" state that fixed the problem with starmade and java in general. Perhaps you can find that option.

    Edit: If you DO find that option, and it is a fix, it would be nice of you to post screenshots for anyone else that runs into that wall.
    That worked, Thanks! ( or maybe it was because I used the newer launcher)
    Here's a screenshot of the control panel and how it should look: Screenshot.PNG
    That circled red drop-list should be set to "High-performance NVIDIA processor" not "Integrated Graphics".
    Now I just gotta learn how to actually play the game...
     
    • Like
    Reactions: AndyP

    AndyP

    Customer Experience Manager
    Joined
    Aug 15, 2013
    Messages
    1,182
    Reaction score
    257
    • Schine
    • Wired for Logic
    Having the High-Performance GPU always active is maybe a bit overkill. (And possibly unwanted on notebooks or just for power saving in general)

    There are also alternative options:
    You could also add the launcher to the programs to run with the "High Performance" processor.

    If you installed the game directly and not via steam, you may have the option to right-click the launcher and use a menu extension labelled: "Execute with..." -> "High-Performance GPU"

    - Andy
     
    Joined
    Aug 22, 2017
    Messages
    4
    Reaction score
    19
    I'm having this same issue with a work computer, only there's no NVIDIA settings like that I can change from what it seems. Sad, because I'd love to NOT work by playing starmade lol. Capture.PNG

    This is the only thing i can seem to find on this computer...
     
    Last edited: