When your IGPU won't load OpenGL in windows

    DrTarDIS

    Eldrich Timelord
    Joined
    Jan 16, 2014
    Messages
    1,104
    Reaction score
    309
    Neat trick to force new OpenGL libraries to execute when intel graphics drivers are being stupid.

    1. get ADK from microsoft
    ->Download the Windows ADK tool that matches your windows version("alt -> File -> help -> about windows" in file Explorer to get your version or just use the newest one if you're all upated like a good doggie.)


    -> you only need the "Compatibility Administrator (64 bit)" and can uncheck the rest, or don't if you are a power use.

    2. Run Compatibility Administrator 64 from windows startmenue
    -> Right click, create an application fix.
    appfix.jpg
    ->Browse to the folder java.exe and javaw.exe are located in. If you're using system java, select that one, if you're using bundled java with starmade go to that folder. name it whatever, documentation is for chumps. Repeat from here for both files.
    appprog.jpg
    ->Ignore compatibility mode. Click next with no boxes filled.
    ->In Compatiility fixes, enable Win81RTMVersionLie and set it's parameters.
    --> type ig4icd64.dll into the module slot, then add it. Hit OK
    -> done with compatibility fixes, click next. Uncheck everything except "product name". Finish.

    ***remember to repeat step 2. both java.exe and javaw.exe need these settings***

    3. Time to tell windows it's graphics driver is an idiot.
    appfix.jpg
    ->Click the save icon, name the database something descriptive. like "solazyintel" or whatever. I don't care where you save it, but the starmade folder is probably good.
    ->Right click and choose "install" under that "create new" you've been using.
    ->may or may not have to reboot PC, so reboot it and make yourself something to drink, you'll need it cause now starmade/java actually loads the OpenGL API for IGPU properly.
     
    Last edited: