1. We've removed some functionality from SMD in preparation for a migration to new forum software. We expect to make the move before the end of August.

    [SOLVED] Game doesn't launch on mac, .dylib files are 0 bytes

    Discussion in 'Game Support' started by req321, Aug 13, 2019.

    Tags:
    1. req321

      Joined:
      Aug 11, 2019
      Messages:
      1
      Hello
      I am using mac 10.11.6. Downloaded Starmade from steam. Launcher works, but when I click launch button the starter java appears, stays for a couple of seconds and closes the game.
      I have tried installing jdk 8, idk 12 reinstalling java.
      From the log i could determine that setting.cfg, I found a thread on the forum about this issue and the was a settings.cfg download.
      Now I get a different error.

      [2019-08-13 22:12:25] [LIBLOADER] ARCHITECTURE x86_64
      [2019-08-13 22:12:25] Exception in thread "main"
      [2019-08-13 22:12:25] java.lang.UnsatisfiedLinkError: /Volumes/New/SteamLibrary Mac/steamapps/common/StarMade/starmade-launcher.app/Contents/MacOS/StarMade/native/macosx/libStarMadeNative.dylib: dlopen(/Volumes/New/SteamLibrary Mac/steamapps/common/StarMade/starmade-launcher.app/Contents/MacOS/StarMade/native/macosx/libStarMadeNative.dylib, 1): no suitable image found. Did find:
      /Volumes/New/SteamLibrary Mac/steamapps/common/StarMade/starmade-launcher.app/Contents/MacOS/StarMade/native/macosx/libStarMadeNative.dylib: file too short

      The log says that libStarMadeNative.dylib: file too short.
      I found that directory and most dylib files were 0 bytes except for libOVR_C.dylib
      I have reinstalled the game multiple times, tried force download in the launcher. The files still stay at 0 bytes
      Here is the full log.

      P.S. Well, I managed to fix this and the game is playable but there is no sound(not a problem)
      I fixed it by taking all of those dylib files from Starmade installed on windows on another computer. It is strange though why so many installations of Starmade failed to download those files on Mac.

      Possible fix:
      Try installing the game with the launcher downloaded from the website.

      Another possible fix:
      It can probably work. You can try to install the game on mac using WINE or Crossover. It will work as if the game was installed on windows. Try to find those files there but the game won't work under WINE so put the files into your normal installation. I haven't tried this method but it might work.
       

      Attached Files:

      #1 req321, Aug 13, 2019
      Last edited: Aug 13, 2019
    Loading...