Server Returning NullPointerException

    Joined
    Dec 5, 2015
    Messages
    108
    Reaction score
    58
    • Community Content - Bronze 1
    Basically what it says in the title, booting up a server, and when it gets to TRADING.tag, it is trying to use the file path Starmade\.\server-database\world0\TRADING.tag which returns java.lang.NullPointerException. Is there a way to fix this?
     
    Joined
    Jan 28, 2017
    Messages
    41
    Reaction score
    65
    have you tried setting up a new world?
    Send your logfile please, its in starmade>>logs>>logStarmade.0.log, make sure that log is from the crash
     
    Joined
    Dec 5, 2015
    Messages
    108
    Reaction score
    58
    • Community Content - Bronze 1
    Well, did a reinstall (force download all & Overwrite), and now getting a completely different error. Log file attached.
     

    Attachments

    Joined
    Dec 5, 2015
    Messages
    108
    Reaction score
    58
    • Community Content - Bronze 1
    Ok, so the server is having problems with the TRADING.tag file which is currently empty. Will try creating a new world, maybe that'll fix something...
     
    Joined
    Jan 28, 2017
    Messages
    41
    Reaction score
    65
    Ok, so the server is having problems with the TRADING.tag file which is currently empty. Will try creating a new world, maybe that'll fix something...
    I tested on my local machine:
    Deleted trading.tag and chatchannels.tag, and started the world, the game automatically replaced them.
    You could try that before loosing your whole world.
     
    Joined
    Dec 5, 2015
    Messages
    108
    Reaction score
    58
    • Community Content - Bronze 1
    I tested on my local machine:
    Deleted trading.tag and chatchannels.tag, and started the world, the game automatically replaced them.
    You could try that before loosing your whole world.
    Well, that solved that error, but now it's having issues with Meta items(...?), so yeah...log attached
     

    Attachments

    Joined
    Jan 28, 2017
    Messages
    41
    Reaction score
    65
    I know thats not ideal but:
    A lot of issues can arise from older installations.
    Uninstalling starmade, redownloading + reinstalling almost always solves these wierd legacy issues.

    You can try copying your worldfolder, and reinserting that into the new install.
    Make sure to really uninstall it and not use the launcher option of "redownload"
     
    • Like
    Reactions: BusterCrabb
    Joined
    Dec 5, 2015
    Messages
    108
    Reaction score
    58
    • Community Content - Bronze 1
    Turns out that deleting the Floating_Items_Archive file worked. No idea why, but it did