server custom textures not displaying on clients?

    Joined
    Jun 30, 2013
    Messages
    175
    Reaction score
    259
    so i've got my custom server textures pack ready to roll.

    folks connect to the server, they receive the pack.zip file with all three resolutions of the texture pack, their client unzips everything in the "\client-database[server address]-custom-textures" folder, but upon the game's launch, their connecting clients do not seem to use them, but the blank templates from their base install folders. they can, of course, copy them to their base install folder's "customBlockTextures" folder, but that seems a bit too cumbersome to be the intended behavior. is there something i am missing somewhere?
     

    kupu

    Colouring in guy.
    Joined
    Jul 4, 2013
    Messages
    1,403
    Reaction score
    1,543
    Had a quick chat with Schema about it, seems like this could be a bug.

    I'll have a chat with Andyp and Lancake about it, see if we can get custom texture sets working on the test server or something.
     
    • Like
    Reactions: plusnine
    Joined
    Jun 30, 2013
    Messages
    175
    Reaction score
    259
    Had a quick chat with Schema about it, seems like this could be a bug.

    I'll have a chat with Andyp and Lancake about it, see if we can get custom texture sets working on the test server or something.
    many thanks, kupu. having spent the last few weeks creating new blocks, i've really gotten to appreciate the time you've taken on the starmade textures in the past year. it's really impressive work and makes long hours of building in starmade fun and easy.

    one other thing i did notice about the client, is that the custom textures do not seem to come in quite as sharp as the game's default textures - i am thinking they may be hard-coded to come in differently than the game's default texture packs, but i can't really be sure. it doesn't make much of a difference from 5 or 6 m off, but it does make a significant one when you're close up. i'll get a screenshot into the post to explain what i mean in a few minutes, just need to head over to my desktop.

    [DOUBLEPOST=1439731565,1439729623][/DOUBLEPOST]

    here's a 10m-away shot of the big part of the project i've been working on, a set of white-paint + grey standard armor crafted letters, numbers, and symbols. i of course started with the grey standard armor texture as a base for each of these. all of this is working fantastically with block properties, faces, rotation, etc. all working beautifully off of the block config. i absolutely love this feature.

    but once loaded into the game, here's how my tiles look side by side to the in-game grey standard armor, you can see the extra blur kicking in (on right) vs. the crisp unfiltered pixels of the in-game texture pack textures (on left):


    this makes their match-up a little more difficult than i had originally anticipated.

    i hope this is useful information, and thanks again for your attention on this matter. i logged onto the test server myself to check things out, and i saw there is indeed a custom texture being distributed, but i checked the shop and crafting for a custom block to try to make with no success. i would be happy to help test any of these features out on the dev build.

    Two other minor thoughts about the block config and custom textures:
    • it would be lovely if we could apply the face texture IDs from the default textures to blocks in our custom array, at the moment, those numbers produce blank faces, and all textures on a custom block must come from the custom texture fileset:

      this relates to the other big project i'm working on: faction emblems, which i'm "decal"-ing onto copies of hull blocks using cutouts of the other hull colors to keep everything uniform and looking like a part of the game. i decided the best way to do this was to have the emblem on two faces, and the hull texture on the other four. i tried to have the custom block config dial in the game's hull textures, but it seems custom blocks must use entirely custom textures. since i coudln't call them up from the texture pack, i put a copy from the texture packs in for each emblem to dial in, but this of course has the effect of doubling the size in the texture file needed for them.
    • having some custom inventory icons (i.e. \image-resource\build-icons-00-16x16-gui-.png ) would be cool too. as the number of custom blocks in the config grows, it becomes difficult to piggyback on the game's existing block inventory icons.
     
    Last edited:
    • Like
    Reactions: Rumcajz

    kupu

    Colouring in guy.
    Joined
    Jul 4, 2013
    Messages
    1,403
    Reaction score
    1,543
    many thanks, kupu. having spent the last few weeks creating new blocks, i've really gotten to appreciate the time you've taken on the starmade textures in the past year. it's really impressive work and makes long hours of building in starmade fun and easy.
    Too kind.

    one other thing i did notice about the client, is that the custom textures do not seem to come in quite as sharp as the game's default textures - i am thinking they may be hard-coded to come in differently than the game's default texture packs, but i can't really be sure. it doesn't make much of a difference from 5 or 6 m off, but it does make a significant one when you're close up. i'll get a screenshot into the post to explain what i mean in a few minutes, just need to head over to my desktop.
    As far as i am aware, there should be no reason for your textures to be reduced in quality by using custom sheets.
    Feel free to send the file in question to me in a PM to check and compare. How are you saving it and with what?

    Two other minor thoughts about the block config and custom textures:
    • it would be lovely if we could apply the face texture IDs from the default textures to blocks in our custom array, at the moment, those numbers produce blank faces, and all textures on a custom block must come from the custom texture fileset:

    • having some custom inventory icons (i.e. \image-resource\build-icons-00-16x16-gui-.png ) would be cool too. as the number of custom blocks in the config grows, it becomes difficult to piggyback on the game's existing block inventory icons.
    I'll have to check both of these points, recent changes allowed us to specify any texture ID for any face, removing the need for duplicate textures. If this doesn't work across both the default t00*'s and a custom sheet (t007), then it needs to be fixed

    Have you tried baking your own icons?
    You can generate a fresh icon ID in the block editor and bake them from your loaded textures in game. Although you may have to specify a custom number a little higher to anticipate new blocks being released... Like i say, i'll have to check these options as i've never actually had to supply custom server side textures.