java.net.ConnectException: Connection refused: connect

    Joined
    Dec 9, 2014
    Messages
    2
    Reaction score
    0
    Hello everyone!
    My name is Wrectoss and I'm an avid fan of Starmade! It's community, though small, is SUPER creative at their craft. So much so that I get motivated everytime someone releases a new carrier class replica from a game I enjoy playing! LUL

    But i digress,
    Today I am having a strange issue with my dedicated server.
    I am using version 0.203.115#20220429_060819 (current recommended build) for the server & cannot seem to get it to announce itself!!

    I am on my 6th day of attempting various google searches which doesn't seem to be helping at all.. aha

    My issue= Server will not announce itself to public server list regardless of port/ip used.
    Announce server is true.
    Server port 4242 has been forwarded and my IPv4 address (public IP) is being used as my server's hostname.
    Secure Uplink is disabled and i've tried using starmade authentication both on and off to no avail.

    The error I frequently recieve on the dedicated server's cmd console is:

    java.net.ConnectException: Connection refused: connect
    at java.net.DualStackPlainSocketImpl.connect0(Native Method)
    at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.<init>(Unknown Source)
    at java.net.Socket.<init>(Unknown Source)
    at org.schema.schine.network.server.ServerSender.annouceServer(SourceFile:49)
    at org.schema.schine.network.server.ServerSender.run(SourceFile:43)


    I have tried,
    Port forwarding 4242, 25565, 8008135
    Changing server pc's (even though public IP is used)
    Restarting network multiple times (who knows, right? :P)
    Re-installing windows (coincidentally was reinstalling windows regardless at that time so i tried this aswell)
    Googling my issue the moment I started encountering it. (approx. 6 days ago)


    Would anyone know what I am missing?
    Any assistance would be GREATLY appreciated ofcourse!!

    If there is any more information you may require please simply ask.

    Thank you for reading,
    Sincerely,
    Wrectoss.