How to play the universe pre-build (FROM A YEAR AGO)

    DukeofRealms

    Count Duku
    Joined
    Sep 4, 2013
    Messages
    1,476
    Reaction score
    1,608
    • Schine
    Hi,

    Just to make this clear, this is not anything new, this is a universe prebuild schema posted in December of 2019. I am posting this as there is nowhere else this information is available, except for Discord.


    What's included in this build?

    Everything completed in the #universe-update-dev-news-bump discord channel. From memory, that is all the backend changes (LWJGL 3, Java 11, some C++ stuff etc.), plus a completed (feature wise) audio system, incomplete new planets and probably other stuff. It is mostly all broken, early development build etc.

    This is a message/warning from schema:

    READ FIRST:

    This is a snapshot build and not meant for general distribution. Just a showcase of one or more specific features.

    These builds are not tested and have a lot of functionality turned off. They shouldn’t be dangerous (like any other build), however in any case Schine GmbH will not take any responsibility for any damages caused by the software. Running this software at your own risk!

    There will not be any support because this build is in full development. Anything you see is subject to change also.

    TIPS & ISSUES

    You will start above a planet if you make a new universe. You can change the type of planet in the server.cfg (TEST_PLANET_TYPE = <0 - 6>). You will have to make a new universe for a different planet to spawn. The seed should also be randomized.

    Planets currently have an issue with the physics (only a small part in the center is physical due to the bounding boxes not updating correctly.

    Also there is an issue with culling polygons on the first load. Once the planet has loaded, you can press F1+F5 to queue a full reload that will get rid of the extra polygons speeding up the performance once it reloaded again.

    The universe is very stripped down at the moment and there might be a few instances where the generation doesn’t work correctly and might cause a freeze. In this case just terminate and try again.

    It should be set by default, buy you can set the <SECRET> tag in settings.cfg to
    GAMEMAPNPCSYSNONPCNOMOBS
    to not have any npcs, mobs, etc spawn that cause issues.