1. Hey Guest! We're currently translating StarMade. Anyone can translate, if you can, feel free to!
      Dismiss Notice
    2. Interested in helping moderate SMD? We're currently looking for moderators, check out this thread.
      Dismiss Notice

    [Guide] Fix the No sound issue in Linux with Steam

    Discussion in 'Game Support' started by MobiusTesseract, Feb 4, 2017.

    1. MobiusTesseract

      Joined:
      Sep 8, 2015
      Messages:
      3
      Hello citizens,

      Today I decided to try StarMade on Linux and ran into the seemingly notorious issue of having no sound. Since I like using Steam I was trying to find a way to still run the game through Steam but make the sound work and found a solution, so I thought I'd share it since no one else has yet.

      I am using Linux Mint. This means the guide should work as is in Ubuntu as well (and probably every other distro but I can't vouch for that, please reply if you try these instructions in a different setup).
      1. Open your StarMade installation directory (probably ~/.local/share/Steam/steamapps/common/StarMade), you can find it using Steam, just click the game's Properties -> Local Files -> Browse local files... button.
      2. Rename "starmade-launcher" to "starmade-launcher.bin"
      3. Create a new empty file called "starmade-launcher"
      4. Paste the following contents inside:
        Code (Text):
        #!/bin/sh
        export LD_LIBRARY_PATH="$PWD/StarMade/native/linux:$LD_LIBRARY_PATH"
        ./starmade-launcher.bin --steam
         
      5. Make "starmade-launcher" executable. If you don't know how to do this, try your file manager's properties dialog under permissions. If you can't do it that way, open a terminal and type:
        Code (Text):
        cd ~/.local/share/Steam/steamapps/common/StarMade
        chmod +x starmade-launcher
      This should do it! Run the game again through Steam and confirm that sound is working. If the game does not start at all make sure you did step 5 right. If it runs but you still have no sound, you may need to follow the instructions in my first link to re-enable the sound system.

      Sources:
      No Sound / Sound stuttering : StarMade Support
      Sound on Linux


      PS: Dear Schine, der_schemeder_scheme has already provided a java method that can solve this problem years ago, why do we still have to go in the trouble of fixing this ourselves? [Linux] No Sound (dev solution inside)
      EDIT: Just realized what the above proposal is and though it's not the proper way to be done, it can still be solved some way programmatically I'm sure! ;)
       
      #1 MobiusTesseract, Feb 4, 2017
      Last edited: Feb 4, 2017
    2. Criss

      Criss Social Media Director

      Joined:
      Jun 25, 2013
      Messages:
      2,160
      We haven't fixed it yet because there is little sound to the game to begin with. When we get sound effects and music from our music producer we can begin the process of putting sound into the game properly.
       
    3. MobiusTesseract

      Joined:
      Sep 8, 2015
      Messages:
      3
      Well that makes sense, I know how disorienting it is to jump from one trivial thing to another while trying to focus on something else, it's just that playing completely silent gets disorienting quickly, even menu sounds and such are something. Anyway, since it's user fixable I agree it can wait for now!
       
    4. bobafetthotmail

      Joined:
      Jan 28, 2017
      Messages:
      16
      Great tutorial! A couple things:

      To get sound working again I also needed to go in the config file .local/share/Steam/steamapps/common/StarMade/StarMade/settings.cfg

      and change S_SOUND_SYS_ENABLED to "true".

      It seems like in-game settings only alter
      S_SOUND_ENABLED
      S_SOUND_VOLUME_GLOBAL
      USE_OPEN_AL_SOUND
      and that was not enough to get sound working again.

      This setting is set when the game first starts on Linux and gives the error message about sound, if you click Continue it will set that to false and afaik you can only change that manually.

      I also would like to note that my Steam here (OpenSUSE 42.2) does not like your script replacing the game launcher so it does not start the game, while executing the script manually (either from command line or by double-clicking on it) works fine and I get sound.

      So this is the script I use (I keep it on my desktop, since it knows the folder on its own I can just double-click on it to start the game)
      Code (Text):

      #!/bin/sh

      #setting folder
      SteamStarmade=".local/share/Steam/steamapps/common/StarMade"

      #moving to folder
      cd ~/"$SteamStarmade"

      #exporting the game's library path folder
      export LD_LIBRARY_PATH="$PWD/StarMade/native/linux:$LD_LIBRARY_PATH"

      #starting the launcher with steam integration
      ./starmade-launcher --steam
       
       
    5. MobiusTesseract

      Joined:
      Sep 8, 2015
      Messages:
      3
      That is correct, I needed to do this as well at some point (though if you click exit to desktop instead of continue it is not needed). This is what I was referring to when I said "you may need to follow the instructions in my first link to re-enable the sound system" but I didn't bother to copy them here. Thank you for adding this, maybe I should put it in the op as well.

      Regarding the script, my whole purpose was to run this through Steam, if you are launching it with an external script I don't think that Steam is aware any more :P
      Are you sure it was executable and it still didn't work? Did you try both launching it manually and through Steam? Did both fail?
       
    Loading...